Landing page not reachable
Incident Report for IPXO Services
Resolved
All the issues related to the ipxo.com landing page were fixed and it is up again. We are marking this case as resolved while continuing to monitor for additional or repeating issues.
Posted Mar 18, 2023 - 18:02 EET
Investigating
We have received notifications from our monitoring system that ipxo.com landing page is not available for some of our clients. We are investigating the situation and will update you as soon as possible.
Posted Mar 18, 2023 - 17:56 EET
This incident affected: Portal (Website).