All the issues related to the ipxo.com landing page were fixed and it is up again. We are marking this case as resolved while continuing to monitor for additional or repeating issues.
Posted Oct 29, 2025 - 14:54 EET
Monitoring
We experienced a temporary outage affecting some IPXO services due to a domain verification hold at our registrar. The verification issue has been resolved, and DNS records are now propagating globally. Some clients may still experience brief service interruptions while DNS caches update.
We expect full service restoration within the next few hours.
Posted Oct 29, 2025 - 14:22 EET
Investigating
We have received notifications from our monitoring system that portal is not available for some of our clients. We are investigating the situation and will update you as soon as possible.